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Overview 

This tutorial is optimized for Echoview 15 and provides an introduction to target detection and analysis in 
multibeam data, such as imaging sonar data. 

This tutorial is not intended as a comprehensive user manual.  

Further information on Echoview tools and topics can be found in the latest version of the Echoview help file. 
This can be viewed online and is installed with Echoview. Press F1 when using Echoview to open the help file 
and read context-sensitive information. 

Throughout this tutorial further reading is referred to the Echoview help file or other Echoview training 
materials: https://www.echoview.com/support 

Prerequisites 

This tutorial assumes you have Echoview installed, and the following skills and knowledge: 

• Familiarity with the basic operation of Echoview. We strongly recommend that you complete the "Getting 
Started with Echoview" tutorial before beginning this tutorial.  

• Familiarity with a supported Microsoft Windows™ operating system. For more information refer to the 
Echoview Help file page: Computer requirements.  

• A basic understanding of echosounding techniques and hydroacoustic surveying. For more information, 
see texts such as Fisheries Acoustics (Simmonds and MacLennan, 2005, Blackwell Science, Oxford.). 

• Microsoft Excel or a similar viewer for spreadsheets. 

 

Echoview modules 

This tutorial requires the Essentials and Multibeam Fish Tracking modules. The optional Automation module is 
used to run scripts. If you do not yet have access to an Echoview license with these modules, please contact 
info@echoview.com to request an evaluation license. Solution files are also included in the tutorial package to 
allow you to see the results of module-protected capabilities. Within the solution EV file, Marker regions 
indicate tutorial selection areas. 

Contacting Echoview  

For assistance with this tutorial please contact support@echoview.com. 

Set up 

We recommend extracting or copying the tutorial files to C:\Echoview Software\Tutorials\. If the files 

are not in this folder, use Windows Explorer to search for them. If they are not loaded on your machine, 
download and reinstall the tutorial from www.echoview.com or from the Echoview USB drive. 

Troubleshooting 

If you receive a message saying that the version of Echoview you are running cannot read the file you have 
opened, you may be running an old version of Echoview. You can download the latest version of Echoview 
from www.echoview.com.  

https://www.echoview.com/support
mailto:info@echoview.com
mailto:support@echoview.com
http://www.echoview.com/
http://www.echoview.com/
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Topic 1: Multibeam target data processing overview 

Data characteristics 

When you view multibeam data, particularly imaging sonar data, you can see fish swimming past the 
transducer. You internally process the time series information about fish shape, fish position and the strength 
of a fish echo.  

The same data can be automatically processed and analyzed with software to estimate fish flux.  

There are advantages in human analysis: 

• sophisticated image and pattern recognition 

• expert knowledge 

There are advantages in software analysis: 

• the ability to process large amounts of data 

• the ability to work with data that the eye can miss 

• the ability to automate routine analysis 

• the ability to provide objective results 

An effective and efficient analysis approach combines those two methods of analysis. 

Workflow 

The analysis of multibeam data is done in two stages: the development stage and the routine analysis stage. 
Both of these stages are discussed in detail in Appendix 1: Stages of multibeam target workflow. 

Although there are many ways to approach or customize multibeam data analysis, the steps presented in this 
tutorial consists of: 

 

 

1. Raw data, as recorded 
by the echosounder 

 

2. Background removal 

 

3. Data smoothing 

 

4. Multibeam target 
detection 
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5. Data filtering, e.g. target 
length 

 

 

6. Conversion of multibeam 
target data to single beam 
target data. 

 

7. Fish track detection 

 

 

8. Exporting fish track 
metrics, then performing 
further analysis such as flux 
calculations, fish property 
correlations. 

 

To see this in practice, we will examine a DIDSON EV file that has echograms showing each step. 

1. Start Echoview by selecting it from the Start menu or by double-clicking the Echoview shortcut on the 
desktop. 

2. On the File menu, click Open. 

3. Browse to and select and open the MultibeamTargetDataProcessingOverview.EV file.  

4. On the Window menu select Arrange All. 

  

 

Figure 1. MultibeamTargetDataProcessingOverview.EV echograms, synchronized to show ping 34. 

The echograms are in an auto-synchronized group. The color scales are optimized to display the data of 
interest. 
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Variable name Description 

Sv frames Displays the multibeam data. 

Multibeam Background 
Removal 

Displays the multibeam data with the background removed. 

Beam median filter 3 x 3 

 

Applies a median filter to the previous data. This step improves 
the definition of the targets. 

Multibeam target detection Applies a multibeam target detection algorithm to the previous 
data. Solid circles represent the detected targets.  Outlines 
represent samples in the target. 

> 20 cm target lengths 

 

The Target property threshold operator applies a minimum 
target length threshold of 20cm to the target data. 

Target conversion Converts thresholded multibeam target data to single target 
data. Fish tracks have been detected on this echogram. 

5. This shows the progression from raw data through noise reduction to specific detected multibeam targets. 
On the File menu, click Close. 

 

Further information 

• The latest information about new or improved multibeam and single targets operators appears in the 
Echoview Help file. 

• New information about Multibeam target detection and new Target properties appears in the Echoview 
Help file under the Contents tab, How to… book, Detect and Work with Multibeam Targets. 
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Topic 2: Viewing multibeam data 

To view multibeam data in Echoview you need to: 

• create a new Echoview EV file 

• add a multibeam data file to a fileset 

• calibrate the data if you have calibration values  

• examine the data 

 

Create an EV file 

1. Start Echoview. 

2. On the File menu, click New. If the New EV File dialog box is displayed, click No Template. 

3. For Fileset 1, in the Data Files section, click Add. 

4. Use the Add Data Files dialog box to find the data file 2002-07-15_#018_HF_S001.ddf and click 

Open. 

This data has been collected from a fixed platform with the transducer pointing across a river. GPS 
information is not included in the data file.  

5. On the Dataflow window  click Platform1, on the Shortcut menu select Platform Properties. 

6. On the Platform Properties dialog box select the Position tab 
Under Platform type select Fixed (if you had the GPS location for the fixed platform, you can enter 
location co-ordinates under Location of GPS antenna.). 

7. Click OK.  

Tips 

• Echoview uses EV files to organize data files and filesets. You might create a single EV file containing all 
the data for a complete survey, an EV file for each transect of a survey, or an EV file for each day of a 
survey. 

• Data files are never modified by Echoview. 

• Refer to the Echoview Help file for more information regarding: 

o Filesets 

o EV files 

Calibrate 

This DIDSON data can be displayed in DIDSON viewer software provided by Sound Metrics. The DIDSON 
software reports that the following information is recorded in the file: 

• Under the Transmission Loss (2*A*R +N*Log R) Processing Parameters section: 

o Temperature = 9 ˚C 

o N = 40 

o A (Auto) = 1.1065 (Value for Absorption coefficient, modelling equation is unknown) 

• Sound speed is 1457 m/s  

• Frequency is 1.8 MHz 

The Echoview Help file page, Sound Metrics notes, discusses the DIDSON transmission loss equation and 
lens mount orientation with respect to Echoview settings. 
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Other multibeam file formats may record instrument and environmental calibration values and Echoview may 
be able to read such values. When Echoview can’t obtain calibration data, it uses default calibration values. It 
is advised that you assess whether default values are suitable for your data. An Echoview Calibration 
Supplement (ECS) file can be used to specify or overwrite calibration values. 

 

8. On the Filesets window, in the Raw variables section, click Sv frames (to highlight). 

9. Click the Echogram button . 

10. In the echogram window, right-click and select Variable Properties (or press F8). 

11. Click the Calibration tab of the Variable Properties dialog box. The settings are red, which indicates that 
they are all default values and not read from the data file. 

12. Close the Variable Properties dialog.  

13. In the Filesets window, click the New button in the Calibration section. At Name type DIDSON_Example 
and then press the Save button. 

14. If prompted, use Notepad or another text editor to view ECS files. 

15. An ECS file with default SOURCECAL settings will open in your text editor. In the ECS text file delete the 
comment symbols (#) at the start of the lines for the following settings, and enter the following values: 

AbsorptionCoefficient = 1.1 

SoundSpeed = 1457 

TvgRangeCoefficient = 40 

 

Figure 2. DIDSON_Example.ecs file with calibration setting edits. 

16. Save the ECS file changes. 

17. You will notice that the data in the Sv frames echogram looks different. This is because of the calibration 
settings that have been applied. Save and close the ECS file.  
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Tips  

• The DIDSON color scheme gradually fades to black and as a result it can be hard to distinguish threshold 
values just above the color display minimum. You can try using another color scheme when tuning 
thresholds by eye.  

• If real-world target locations are important, Echoview offers Transducer geometry settings for Location and 
Orientation.  

• Sound speed and absorption coefficient in fresh water can be calculated. Echoview offers a Sonar 
calculator that calculates sound speed and absorption coefficient. It is available under the Help menu, 
Sonar Calculator. It is advisable to review the equations used by the Sonar calculator because the 
modelling equations have restrictions. 

• Refer to the Echoview Help file for more information regarding: 

o Multibeam and imaging sonar data formats 

o Color schemes 

o Transducer geometry 

o Calibration 

Inspect 

18. In the Raw variables section of Fileset1, click Sv frames. 

19. Click Echogram. 

20. Use the DVD controls to navigate the frames of the echogram. Drag the slider to quickly view the ping 
data. 

21. Press F11 and F12 to change the Color display minimum. 

22. Right-click the Color Legend. Enter: 
Display minimum = 79 
Display range = 35  

 

   

Figure 3. DIDSON echogram in Echoview, showing the beam fan for one ping (ping 34). 
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23. Click the Variable Properties tool  or press the shortcut key F8.  

24. Select the Echogram Display tab. 

25. From the Color scheme list, select EK500. 

26. Click OK. 

27. Press F11 and F12 to change the Color display minimum. 

28. Revert to the DIDSON color scheme (use steps 22-25).  

29. On the Variable Properties dialog box under Echogram colors section enter the settings: 
Color display minimum: 79 
Color display range: 40 

30. Click OK. 

31. Go to ping 34 of the echogram. (You can press CTRL+G to open the Go To dialog and then enter 34) 

32. View the Details dialog box. Click the Details tool  to open it if it is closed. 

33. Move the mouse cursor over a fish. 
The Details dialog box, the Information toolbar and the Echoview status bar will update with information 
relating to beam, beam angle, range, depth, ping number etc. 

34. Click the Tape measure tool . 

35. Click and drag from one point to another. 
The distance is displayed. 

36. Click the Rectangle selection tool . 

37. Draw a selection around a feature. 

38. Press S to zoom. Press U to zoom out. 
Zoom is also available with the mouse wheel and on the Zoom toolbar. 

39. Save your progress: on the File menu, click Save As. 

40. Select the folder in which the tutorial data have been saved. 
If you used the standard installation settings, this will be: 
C:\Echoview Software\Tutorials 

41. In the Filename box, type ViewingData 

Echoview adds the .EV file extension automatically when you save the file. 

42. Click Save. 
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Further information 

• Further display settings are found on the Display page and the Grid page of the Variable Properties 
dialog box. 

• The Details dialog box can be configured and locked. Information can be copied from the Details dialog 
box to another software program. 

• When several windows are displayed, Echoview can arrange them using the options under the Window 
menu. They can also be synchronized with a Shortcut command (A) or added to a synchronized group 

using the Autosynchronize window tool . 

• The Variable Properties dialog box (F8 or ) settings affect variables.  

• The EV File Properties dialog box settings (F6 or ) affect the EV file. 

• Echoview Configuration dialog box settings (File menu > Configuration) affect Echoview. 

• Multibeam echogram analysis is made easier with multibeam keyboard display shortcuts, replay shortcuts 
and the playback rate shortcut. 

• Refer the Echoview Help file for more information regarding: 

o Tools 

o Dialog boxes 

o Synchronization of echograms 

o About keyboard shortcuts 

o About user defined keyboard shortcuts 
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Topic 3: Background noise removal 

In this topic you will learn about background noise removal techniques for multibeam data. 

Operators in Echoview 

A powerful way to process echogram data is to use synthetic or virtual echograms. Virtual echograms are 
called virtual variables in Echoview and are created using operators. 

For further information, refer to the Echoview Help file Virtual variable applications page. 

Note: The creation of new virtual variables can happen via a selected variable or via no selected variable. The 
New Virtual Variable dialog box filters offered operators in relation to a selected variable. To remove the 
filtering, especially in the selected variable case, clear the setting Only show operators which are 
compatible with the selected variable. 

About background noise 

Background noise in multibeam data can affect target detection and make the review of detected targets with 
respect to original data more difficult. 

Sources of background noise include: 

• Stationary objects 

• Objects that move slowly 

Echoview offers a number of tools to remove or minimize background noise. The Echoview Help file 
discusses: 

• Background noise in Echoview 

• Background noise removal  

Multibeam background noise removal 

The Multibeam Background Removal operator removes stationary and slow moving objects. It is designed for 
multibeam data and calculates a statistic from a window of pings around the current ping. This statistic is 
intended to capture the static background elements present in the data. It then subtracts that statistic from the 
current ping, leaving the data of interest without any background. 

43. Open ViewingData.EV file that you saved earlier, or ViewingData (Solution).EV if you did not 

save an EV file in earlier steps. 

44. View the Dataflow window (press F7). 

45. Click in an empty area to ensure no variables are selected. Right-click and on the Shortcut menu select 
New, Variable to open the New Virtual Variable dialog box. 

46. In the Select operator section, select Multibeam background removal, click OK. 

47. On the Variable Properties – Multibeam background removal 1 dialog box, use the Operand 1 list to 
select Fileset1: Sv frames. 

48. Select the Name and Notes page, under Name correct the name to Background noise removal. 

49. Select the Background Removal page. Enter the following settings: 

o Window size = 41 

o Algorithm = Nth Percentile 

o Percentile = 60 

o Minimum SNR = 10 

Press F1 to display information on these settings. 

50. Click OK. 
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51. Double-click the Multibeam Background Removal variable in the Dataflow window to view the 
echogram. 

52. Close the Dataflow window, go to the Window menu and select Arrange All to automatically adjust the 
window sizes. 

53. Use the DVD controls to view ping 34. Press A to synchronize the echograms. The Multibeam Background 
Removal operator has removed stationary objects, slowly moving objects and some noise, whilst leaving 
behind the fish moving through the beams, as shown in Figure 4 below. 

54. Save the EV file as MultibeamBackgroundRemoval.EV. Close the EV file. 

 

 

Figure 4. Sv frames and Multibeam Background Removal echograms (ping 34). 

Further information 

• Refer to the Echoview Help file for more information regarding: 

o Operators 

o Virtual variables 

o The Dataflow window 

o Multibeam echograms  

o Autosynchronization tool 
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Topic 4: Improving target definition 

Our goal is to reliably and efficiently identify fish (or other targets) in multibeam data. To that end, we process 
the data with software tools so that fish are easy to see. 

The verification of automated processing relies on the positive correlation of the numerical results with our 
inbuilt visual processing and expert knowledge. 

The definition of targets prior to multibeam target detection can be improved in Echoview through: 

• Echogram color display settings 

• Data threshold settings 

• Multibeam convolution operators 

This topic uses the Beam median filter 3x3 operator as a mild smoothing filter – it smooths the image without 
significantly affecting fish shape. Further smoothing is possible using any combination of Echoview’s 
multibeam convolution operators. For example, to preserve size use a dilation filter followed by an erosion 
filter.  

Color scheme 

It may be useful to change away from the default DIDSON color scheme when you’re tuning the threshold by 
eye. The DIDSON color scheme gradually fades to black, which makes it very hard to distinguish low values. 

Display and data thresholds 

A data threshold must be set on the variable that acts as the source for the multibeam target detection 
operator. The threshold here is critical – it will determine what’s detected as a multibeam target and what is 
not. 

A single threshold is preferable because it makes results more repeatable and the thresholds easier to tune. 

Using as low a threshold as possible is optimal because it preserves the fish image in one piece rather than 
breaking it into multiple fragments. It is preferable to have some “speckle” and the fish in one piece (as in 
Figure 5 below), than it is to remove all speckle and have broken fish. Speckle can be removed later via 
strategies such as thresholds, fish tracking and filtering with target properties. 

An iterative strategy 

Once you have a complete chain of virtual variables (to the step before fish tracking) choose a data threshold 
by locking it to the display threshold and adjusting the threshold while watching the resulting single targets 
echogram. There’s usually a distinct transition where no extra fish are detected but lots of additional “speckle” 
starts to appear. If the transition isn’t distinct, the speckle can be dealt with using a length threshold in an 
additional virtual variable.  
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Figure 5. Sv frames (left), Beam median 3x3 median operator with EK500 color scheme (right). 

Create a Beam median filter variable 

55. Start Echoview. 

56. On the File menu, click Open. 
Open your saved MultibeamBackgroundRemoval.EV file  
- OR - 
Echoview 

Software\Tutorials\IntroToMultibeamTargetDataProcessing\MultibeamBackgroundRem

oval (Solution).EV 

57. Close the Multibeam Background Removal echogram. 

Click the Dataflow tool  

58. Click in an empty area to ensure no variables are selected. Right-click in an empty area of the Dataflow 
window and select New, Variable from the Shortcut menu. 

59. In the New Variable dialog box, in the Select operator section, click Beam median filter 3x3, click OK 

60. On the Variable Properties – Beam median filter 3x3 1 dialog box, use the Operand 1 list to select 
Multibeam background removal. 

61. On the Name and Notes page, under Name correct the name to Beam median filter. 

62. Double-click on the Sv frames variable and the Beam median filter variable. 

63. Close the Dataflow window. 

64. Click the Sv frames echogram to activate it. 

65. Check that the Autosynchronization tool  is highlighted. If it is not, click . 

66. Click the Beam median filter echogram. 

67. Click Autosynchronization tool  

68. Go to ping 34. 
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69. Click the Variable Properties tool  (while the Beam median filter echogram is active). 

70. Select the Echogram Display tab. 

71. In the Echogram colors section enter the settings: 
Color display minimum: 41 
Color display range: 70 
Color scheme: EK500 

72. Select the Data tab. 

73. Under Minimum threshold select Apply. 

74. Under Maximum threshold select Apply. 

75. Click OK. 

76. Adjust the display and data thresholds on the median filter echogram using F11/F12 keyboard shortcuts. 
Observe the behavior of the speckle and the integrity of the fish. 

77. On the File menu click Close (to close the solution EV file). 
- OR – 
Save your EV file as ImproveTargetDefinition and Close. 

Further information 

Refer to the Echoview Help file for more information regarding: 

• Convolution algorithms 

• Convolution operators illustrated 

• Variable properties dialog box Display page 

• Variable properties dialog box Data page 
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Topic 5: Target detection 

In this topic you will learn about multibeam target detection. 

About multibeam targets 

Echoview detects above-threshold clusters of samples and stores them as point targets with range, beam, 
mean_Sv (called TS) and target properties. 

Multibeam target detection echograms show targets as large colored points. By default, samples that 
contribute to the target are displayed with a highlighted outline. 

 

Figure 6. Sv frames (left), Multibeam target detection operator (right) using the EK500 color scheme. 

Target properties 

Target properties calculated in Echoview can be used in target filtering, target review and target classification. 
You can select the target properties to calculate – some properties may be more useful than others and virtual 
variable data generation times can vary for the number of and type of target property. By default, all target 
properties are calculated. 

Target properties include: 

• Target area (cm2) 

• Target area edge midpoints (cm2) 

• Target compactness 

• Target compactness edge midpoints 

• Target length (cm) 

• Target length across beams (cm) 

• Target perimeter (cm) 

• Target perimeter edge midpoints (cm) 

• Target intensity variation 

• Target range extent (cm) 

• Target orientation (º) 

• Target thickness (cm) 

The following manual measurements can also be stored with targets: 
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• Target length (manual) made using the Tape measure tool. 

• Target class applied using the Target classification tool. 

 

Tips 

Refer to the Echoview Help file for more information regarding: 

• Target properties from multibeam data 

• Target length manual and Target metadata 

• The Multibeam target detection operator 

• About surfaces. You can use Exclude above and Exclude below surfaces to limit the target detection to a 
suitable space. This may also improve detection time, because unwanted data is not processed.  

Create a Multibeam target detection variable 

1. Start Echoview. 

2. On the File menu, click Open. 
Open your saved ImproveTargetDefinition.EV file  

- OR - 
ImproveTargetDefinition (Solution).EV 

3. Click the Dataflow tool  

4. Click in an empty area to ensure no variables are selected. Right-click in an empty area of the Dataflow 
window and select New, Variable from the Shortcut menu. 

5. In the New Variable dialog box, in the Select operator section, click Multibeam target detection, click 
OK 

6. On the Variable Properties – Multibeam target detection 1 dialog box, use the Operand 1 list to select 
Beam median filter. 

7. On the Name and Notes page, under Name correct the name to Multibeam target detection. 

8. Click the Target Detection tab 

9. Click the Advanced button to see the default target detection settings. Inspect the Advanced settings; use 
F1 to display context sensitive Help file information. Press OK to close this window. 

10. Click the Target tab. 
You can select target properties to calculate – the default setting includes all target properties. 
You can also select a TS strength source from the list – the TS source affects the single target variable 
that can be created after the multibeam target detection stage. 
 
Note: The Target_length_across_beams property is faster to calculate than the Target_length property 
and it can be more accurate for situations where fish are swimming perpendicular to the central beam. 

11. Click the Echogram Display tab, inspect the Multibeam settings for sample value display range and 
target-sample outline.  Set Color display minimum = 66 and Color display range = 40. 
Under Multibeam select Show input data under targets, Show target outlines and Show target 
sample outlines 

12. Click OK to close the Variable Properties dialog and create the new variable. 

13. Double-click on the Sv frames and Multibeam target detection variables and close any other windows 
that may be open. 

14. Click and drag the echogram windows to rearrange them so that they are side by side. 

15. Click the Sv frames and then Multibeam target detection echograms. Check if the echogram is in an 

Autosynchronization group. If not, click the Autosynchronization tool  
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16. Go to ping 34 (press Ctrl+G to open the Go To dialog and then enter 34). 
Both the Sv frames variable and the Multibeam target detection virtual variable are synchronized and 
display ping 34. 

17. On the Multibeam target detection echogram zoom in on a target (refer to Topic 2). The color scheme for 
the input data under targets is controlled by the input operand Beam median filter 3x3. To match the inset 
for Figure 7 you may need to adjust the Echogram color settings of the Beam median filter variable. 
Beam median filter: Display minimum = 70 dB, Display range = 41 dB. Adjust F11/F12 on the Beam 
median filter echogram, while viewing the target. 

 

 

Figure 7. Close up of the highlighted multibeam target in ping 34. 

18. The (highlighted) detected target at 6.1 m is represented by a colored circle. Samples that contribute to 
the target are shown and outlined. 

19. Move the cursor over a detected target (marked by the colored circle) and observe the displayed 

information in the Details dialog box . 
Hint: You may need to scroll down in the Details dialog box to see the information in the Target section. 
Or you can use Details dialog box View list dialog to toggle Details sections that you want to minimize. 

Manual target length 

20. Observe the target length in the Details dialog box. 

21. Click the Tape measure tool . 

22. For this target, click, drag and release from one edge of the contributing samples to the other. The 
distance is displayed. 

23. Move the cursor over the circle at the center of the target. 
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24. Right-click and select Store Target Length on the Shortcut menu. 
The manual target length measurement is stored with the target. 
The displayed target will now display a thick outline for the center circle to indicate that this target has a 
manual length measurement. The Length (manual) is also displayed in Details.  

 

Figure 8. Detected target at 6 m now has a stored target length. 

Tips 

• Length and Length (manual) are both displayed in the Details dialog box. 

• View menu > Target Metadata will open a window that manages manual target lengths. You can delete 
manual target lengths in this window. 

• Use the Maximum Intensity operator to: 

o Identify targets missed by the multibeam target detection. This is useful when tuning the detection 
settings.  

o Identify target swim-shape and "tail beat" rate which can assist in species identification as 
discussed by Mueller et al. (2010).  

Create a Target property threshold variable 

At this point a target property threshold can be applied to the multibeam target detection variable. 

Alternatively, a target property threshold can be applied to the single target variable created by the target 
conversion of the multibeam target detection data. 

The Target property threshold operator does not affect the attributes that are displayed in the echogram but 
does affect whether each target is included or not. 

This topic will demonstrate a target property threshold applied to a multibeam target detection variable. 

1. Click the Dataflow tool  

2. Click in an empty area to ensure no variables are selected. Right-click in an empty area of the Dataflow 
window, and select New, Variable from the Shortcut menu. 

3. In the New Variable dialog box, in the Select operator section, click Target property threshold, click OK 

4. On the Variable Properties – Target property threshold 1 dialog box, use the Operand 1 list to select 
Multibeam target detection. 

5. On the Name and Notes page, under Name correct the name to > 20cm target length. 

6. Click the Target Property Threshold tab. 
For Threshold targets by: select Target length. 
Select Apply minimum threshold. 
Enter 20.00  
Click OK 

7. Double-click on the > 20cm target length virtual variable. 
Restore the Multibeam target detection variable. 

8. Close the Dataflow window. 

9. Tile the echograms side-by-side. 
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10. Click the > 20cm target length echogram. 
Hint: To see more target-circles with lengths greater than 20cm, the Color scheme display minimum and 
range may need adjustment.  

11. Click Autosynchronization tool . 

12. Observe the targets in the >20cm target length echogram – there are fewer targets than the Multibeam 
target detection echogram. 
 
The length filter removes a large proportion of the “speckle” targets as well as some genuine targets that 
were detected as fragments. Fish tracking on the single target data (converted from the multibeam target 
detections) would produce a set of tracks that require much less manual editing than those detected from 
the unfiltered target variable. 

 

eso 

Figure 9. Ping 45. On the left the multibeam target detection variable is displayed.  On the right the target property 
threshold variable displays all targets that are greater than 20cm in target length. 

13. Close the >20cm target length echogram. 

 

Target conversion  

To be able to use more of Echoview’s powerful tools with multibeam target data you need to use the Target 
conversion operator to convert multibeam target data to single target data.  

Single target tools include: 

• Visualization 

• Data and analysis exports 

• Fish tracking 

• Graphs 

The target conversion echogram represents multibeam targets as single target traces. The traces may indicate 
potential fish tracks that could be checked against detected fish tracks. In ideal data, traces should be 
complete (no missing pings) and they should not split or merge. It maybe useful to compare individual traces 
that show problems with the original multibeam image. 
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Figure 10. Single target variable derived from the Target conversion operator. 

Create a Target conversion variable 

14. Click the Dataflow tool  

15. Click in an empty area to ensure no variables are selected. Right-click in an empty area of the Dataflow 
window and select New > Variable from the Shortcut menu. 

16. In the New Variable dialog box, in the Select operator section, click Target conversion, click OK 

17. On the Variable Properties – Target conversion 1 dialog box, use the Operand 1 list to select > 20cm 
target length. 

18. On the Name and Notes page, under Name correct the name to Single targets > 20cm target length. 

19. Click the Echogram Display page. 

20. In the Echogram colors section enter the settings: 
Color display minimum: 70 
Color display range: 40 
 
Under the Data page: 
Thickness source: Target thickness 
Thickness factor: 0.75 
Click OK. 

21. Double-click the Single targets >20cm target length virtual variable. 

22. Observe the groups of single targets and the traces they follow. 
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Tips 

• If working with a large volume of data, a performance workaround can be achieved by using Echogram > 
Export > Single targets from a single target variable. If the resulting single target csv file is added to a new 
Fileset the performance for many operations (including basic navigation of the echogram) will be 
significantly improved. Target properties are preserved during the export/add loop. See Topic 9 for more 
details on this. 

• For further discussion about target traces refer to Appendix 1.  

• Refer to the Echoview Help file for more information regarding: 

o Analysis exports 

o Data exports 

o How to detect and work with single targets 

o Create a TS substitution variable 

TS substitution  

Target properties can be exported for analysis outside of Echoview but they can also be visualized within 
Echoview. The TS substitution operator creates a single target variable where other values can be substituted 
for TS and/or TS_uncomp. 

TS substitution using Target length across beams 

The Target_length_across_beams property is faster to calculate than the Target_length property and it can be 
more accurate for situations where fish are swimming perpendicular to the central beam. 

23. Click the Dataflow tool  

24. Click in an empty area to ensure no variables are selected. Right-click in an empty area of the Dataflow 
window and select New > Variable from the Shortcut menu. 

25. In the New Variable dialog box, in the Select operator section, click TS substitution, click OK 

26. On the Variable Properties – TS substitution 1 dialog box, use the Operand 1 list to select Single targets 
> 20cm target length. 

27. On the Name and Notes page, under Name correct the name to Target length across beams. 

28. Select the TS Substitution page  
In the TS Value section 
Select Target length across beams from the Populate TS with values from: list. 
Select the Echogram Display page 
Color display minimum = 14.00 
Color display range = 100 

29. Select the Data page 
Thickness source = Target thickness  
Thickness factor = 0.2 
Click OK. 

30. In the Dataflow window double-click the Target length across beams variable. 
 
You can arrange the echogram, Color legend, Details dialog and zoom like the following figure. The 
arrangement facilitates the visual scrutinization of detected targets with respect to Target_length_across_ 
beams. 
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Figure 11. Target length across beams echogram. 

The Target length across beams echogram displays single targets that are colored according to their 
Target_length_across_beams value. In the figure the mouse pointer is on a pink target. The highlighted area 
in the Details window shows the value of the Target_length_across_beams in “TS value” and the TS uncomp 
value of the target. 

 

TS substitution using Target range extent 

The Target range extent property could be used to analyze the target's swim-shape1. When 
Target_range_extent is of the order of the Target_thickness, the target is fully extended and straight. While the 
target swims the Target_range_extent will vary between the Target_thickness and the value that reflects the 
maximum swim-shape. This "Tail-beat" could be correlated to a selected (and repeated) value of 
Target_range_extent. 

1. Click the Dataflow tool  

2. Click in an empty area to ensure no variables are selected. Right-click in an empty area of the Dataflow 
window and select New, Variable from the Shortcut menu. 

3. In the New Variable dialog box, in the Select operator section, click TS substitution, click OK 

4. On the Variable Properties – TS substitution 1 dialog box, use the Operand 1 list to select Single targets 
> 20cm target length. 

5. On the Name and Notes page, under Name correct the name to Target range extent. 

6. Select the TS Substitution tab  
In the TS Value section 
Select Target range extent from the Populate TS with values from: list. 
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7. Select the Echogram Display tab 
In the Echogram colors section, 
Color scheme: DIDSON 
Color display minimum = 3.00 
Color display range = 30.00 

8. Select the Data tab 
Thickness source: Target thickness 
Thickness factor: 0.50 
Click OK. 

An echogram of Target range extent under a DIDSON color scheme displays target traces that look like 
caterpillars. With the Target range extent as the Thickness source, the tail-beat information can appear as 
(regularly-spaced) “legs” along the body of the caterpillar. The “legs” stand out from the “body” of the 
caterpillar in two ways. The color scheme assigns a light color to the big values of range extent and the target 
display thickness is at full extent. 

t 

Figure 12: Target range extent substitution echogram. 

TS substitution using Angle major axis 

TS substitution using the major axis angle can be useful as a proxy to identify targets that swim through the 
beam and to separate target traces. A target that swims through the beam fan will display an expected 
progression of major axis angle values that can be visualized. The Sonic color scheme follows the colors of a 
rainbow. As a result, a target that passes through the beam fan will display the (orderly) colors of a rainbow. 
The steps to create a TS substitution variable with Angle major axis are similar to the Target range extent 
steps.  
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Figure 13: Angle major axis substitution echogram. The lower red arrow shows how the rainbow separates different target 
traces. The upper red arrow shows how the rainbow can provide insights for problematic targets. 

Create a Multibeam overlay variable 

The Multibeam target overlay operator overlays multibeam targets on specified multibeam data. This is useful 
in scrutinizing detected targets against original data (and can also be used to approximate the DIDSON viewer 
display).  

Tips 

• The display of multibeam target data from the first operand is affected by the color scheme of the 
Multibeam target overlay variable. Similarly, the multibeam target overlay Data tab minimum and 
maximum color display thresholds control the visibility of overlaid targets.  

• Displayed echogram data from the second operand is affected by the settings of the second operand. 
It may be necessary to adjust the second operand’s color display settings to improve the viewing of 
the specified multibeam data under the multibeam target overlay echogram.  

1. Click the Dataflow tool  

2. Click in an empty area to ensure no variables are selected. Right-click in an empty area of the Dataflow 
window and select New, Variable from the Shortcut menu. 

3. In the New Variable dialog box, in the Select operator section, click Multibeam target overlay, click OK. 

4. On the Variable Properties – Multibeam target overlay 1 dialog box, use the Operand 1 list to select 
Multibeam target detection. Use the Operand 2 list to select Fileset1: Sv frames. 

5. On the Name and Notes page, under Name correct the name to Overlay original data with detected 
targets. 
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6. Select the Echogram Display tab  
In the Echogram colors section 
Color display minimum: 70 
Color display range: 40 
Color scheme: EK500 
 
In the Multibeam display section 
Select: 
Show input data under targets 
Show target sample outlines 
Click OK and view the echogram for the resulting variable. 

7. On the Dataflow window, right-click the Fileset1: Sv frames object and select Variable Properties. 
Select the Echogram Display tab 
Color display minimum: 63.00 
Color display range: 41.00  
Color scheme: DIDSON 
Click OK 

8. On the Multibeam target overlay echogram, move the Time slider back and forth to view detected targets 
overlaid on the primary data. 

 

Figure 14: Multibeam target overlay, ping 31. Detected targets overlaid on Sv frames data. 

 

Looped multibeam replay 

The Looped multibeam replay feature synchronizes the display of selected single targets with data in 
multibeam pings. Use it to verify detected targets against original data. 

1. Display the Target range extent echogram. Display the Multibeam target overlay echogram. You can 
arrange the Target range extent echogram (use zoom), Details dialog box and Target overlay echogram 
like the figure below. The arrangement facilitates the visual scrutinization of detected targets with respect 
to Target_range_extent and the original multibeam data. 

2. Click the Rectangular selection tool . 

3. With the mouse pointer, draw a rectangular selection around a target(s) of interest on the Target range 
extent echogram. The targets follow a trace – a potential fish track. 

4. On the Shortcut menu choose Looped multibeam replay. Observe the synchronization between the 
single target echogram and the multibeam echogram, and the visual indicators shown on each. 

5. New selections can be viewed by repeating steps 2, 3, 4. 
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Figure 15. Using the Details dialog box, Multibeam target overlay variable and Target range extent variable and Looped 

multibeam replay to study fish swim shape and tail beat frequency. 

6. To stop using the looped multibeam replay feature: 
Click the stop control on the multibeam echogram. 
On the Time slider, right-click and select Clear replay limits. 

7. On the File menu click Close (to close the solution EV file). 
- OR – 
Save your EV file as Multibeam target detection and Close. 

 

Further information 

• Looped multibeam replay can be used with echograms that are in an auto-synchronized group. This 
allows you to view the original data and other stages of the processed data. 

• Refer to the Echoview Help file for more information regarding: 

• How to use looped multibeam replay  

• Synchronized and auto-synchronized echograms 
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Topic 6: Fish tracks 

Before you start this topic we advise you to complete Echoview’s Introduction to Fish Tracking tutorial to gain 
some understanding and experience with fish track detection, editing, examination and analysis. Although it 
uses single beam data, the general philosophy for fish tracking in Echoview is the same for both single beam 
and multibeam data, with only minor differences. 

In this topic you will learn about generating analyses of fish tracks from detected targets in multibeam data. 

Fish tracking with multibeam data 

Fish tracking for multibeam-derived single targets is slightly different than for split-beam targets because there 
isn’t any minor-axis position information. 

Tracking from multibeam data (for well-defined fish movements) often requires little editing of automatically-
detected tracks, because the across-fan angle is well defined and very consistent compared with split-beam 
data. Having two axes, each with highly accurate positioning gives better results than three axes where there 
is relative positional inaccuracy on two axes.  

 

Figure 16. Detected fish tracks for targets in multibeam target data. 

Analyzing the fish tracks produces a mean length and mean intensity statistic for each fish track, as well as 
other metrics. 

Echoview provides two ways of generating analyses of fish tracks: 

Method Description 

On-screen analysis Displays a subset of analysis results for a single fish track.  

Export analysis Exports full analysis results for all fish tracks (or a selected class of 
fish track) in a selection or the whole echogram. 

The data are exported to comma-separated value (*.csv) files and can 
be opened in most spreadsheet applications. Some exports can also 
be formatted for use with database applications. 

Detecting fish tracks 

In this exercise you will detect fish tracks in a single target variable derived from multibeam target data. The 
settings for fish tracking are guided by the movement of the single targets (fish) in your data. An examination 
of the single target echogram and single target graphs may reveal the relative importance of things like major 
and minor axes, range and TS. The iterative tuning of the fish track detection settings is quick, as is the 
assessment of the resulting fish tracks.  

The tutorial ‘Introduction to Fish tracking’ demonstrates the use of fish track editing tools and single target 
graphs. 

A license for the Multibeam Fish Tracking module is required to detect fish tracks in multibeam data. 

 

1. Start Echoview. 
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2. On the File menu, click Open. 
Open your saved Multibeam target detection.EV file  
- OR - 
C:\Echoview 

Software\Tutorials\IntroToMultibeamTargetDataProcessing\MultibeamTargetDetecti

on (Solution).EV 

3. Open the Single target >20cm target length echogram. 
Close all other echogram windows (if still open). 

4. Click the EV File Properties tool  

5. On the Echogram page, under the Show on echogram section, clear Region classes. This leaves the 
echogram display clear of the Region class name for every detected fish track. 
Click OK. 

6. On the Echogram menu, select Detect fish tracks. 

7. Click Edit. 

8. In the Region classes section, click New. 

9. On the Name and Notes page under Name enter Greater than 20cm target length. 
Click OK. 

10. Click OK to close EV File Properties dialog box. 

11. On the Detect Fish Tracks dialog box, under Assign class select Greater than 20cm target length. 

12. Click Properties to enter track detection settings. 
On the Algorithm page. 
In the Data section select 4D. 
In the Track detection section enter: 
Alpha: 0.5, 0.5, 0.5 
Beta: 0.2, 0.2, 0.2 
In the Target gates section: 
Exclusion distance: 0.2, 0.2, 0.2 
Missed ping expansion: 0.0, 0.0, 0.0 

13. On the Weights page. 
Major axis: 100 
Minor axis: 0.0 
Range: 25 
TS: 50 
Ping gap: 50 

14. On the Track acceptance page. 
Minimum number of single targets in a track: 8 
Minimum number of pings in a track: 3 
Minimum gap between single targets: 3 

15. Click OK 

16. Click Detect. 
The fish tracks are displayed as regions that enclose single targets on the echogram. You can use fish 
track editing tools to merge or split detected tracks and create tracks (that may have been missed by the 
detection). Single target graphs of fish tracks may be useful for fish track setting tuning.  

Note: The detection may flag the presence of invalid fish tracks. Information about the nature of the 

invalid tracks is sent to the Messages dialog box . See also Help file: About fish track regions: 
Validity. 

On-screen analysis 

17. Click the Region Browser tool . 

18. Select a fish track (The region border around the active fish track thickens and becomes animated.) 



 

Echoview Tutorial: Introduction to Multibeam Target Detection Page 33 of 46 

 

19. On the Shortcut menu, click Analyze Fish Track. 

 

  

Figure 17. Fish track analysis results for Region 7 in  the saved  EV file or Region 8 in  the solution EV file. 

20. On the Fish Track Analysis Results dialog box select the Linked checkbox to synchronize the active fish 
track in the Region Browser or the Single targets >20cm target length echogram with the Fish Track 
Analysis Results dialog box. 

21. On the Region Browser click the Prev and Next buttons to look at other fish tracks, or click on different 
tracks on the echogram itself. 

Tips 

• Refer to the Echoview Help file for more information regarding: 

o The Region browser 

o Fish track analysis variables 

o How to detect and work with fish tracks 

Exporting fish tracks 

A license for the Essentials module is required to export fish track analysis results.  

To set up an export you will need to display a grid, select export variables and select the type of output file. 

Note: Some analysis variables are exported automatically. 

1. Close the Fish Track Analysis Results dialog box. 

2. Click the Variable Properties tool . 

3. Click the Grid page. 

4. In the Display and analysis grid section enter the following: 
Show time/distance grid: Time (minutes) 
Time between grid lines (minutes): 0.5 
Show depth/range/line-referenced grid: Water surface (depth of zero) 
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Separation (m): 12 
Click OK 

5. Click the EV File Properties tool .  

6. Open the Export page. 

  

Figure 18. Export page of the EV File Properties dialog box. 

 

Select the export analysis variables. 

1. Clear these groups: 
Analysis domain, Biomass, Bottom, Frequency distribution, Integration results, Integration schools and 
Integration settings. 
Expand Analysis common and select 
Date_M, Dist_M, Lat_M, Lon_M, Num_intervals, Num_layers, 
Ping_M, Time_M  
 
Expand Analysis export and select: 
EV_filename, Processing_date, Processing_time, Processing_version,  
Program_version 
 
Expand Fish tracks and select 
Direction_horizontal, Fish_track_change_in_range, Speed_4D_mean_unsmoothed, Time_in_beam 
 
Expand Single targets and select: 
Num_targets, Target_depth_mean, Target_length_mean, Target_range_mean, TS_mean,  
 
Clear the checkbox of any variables that you don’t want to export. 
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2. In the Format section select Spreadsheet format (single file). 
Click OK. 

3. On the Echogram menu select 
Export, Analysis by Cells, Fish tracks 

This opens the Export fish tracks – Select Classes dialog box. 

4. Under the Region classes to export: section select Greater than 20cm target length. 

5. Click Export... 

6. Browse to the IntroToMultibeamTargetDataProcessing folder (e.g., C:\Echoview 

Software\Tutorials\IntroToMultibeamTargetDataProcessing).  

7. For Filename enter Greater than 20cm target length by cells. 

8. Click Save. 

9. On the File menu click Close (to close the solution EV file). 
- OR – 
Save your EV file as MultibeamFishTtrackDetection and Close. 

Tips 

Create a Fish track analysis exporter object on the Dataflow window. An exporter enables repeatability and 
annotation of an export.  

Further information 

• Refer to the Echoview Help file for more information regarding: 

o Exporting analyses 

o Export variables 

o Spreadsheet and database export files 

o Cells, intervals and layers 

o About exporters 
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Topic 7: Calculations and graphs 

Exported fish track analysis data can be processed in a number of ways to reveal useful numerical information 
and trends about the observed fish.  

This tutorial shows you one variation of calculations and graphs that can be derived from the exported data in 
Topic 6. 

.csv file processing 

Valid and invalid fish track regions may have been exported into the .csv. Invalid fish tracks should be 
removed prior to further work on the CSV file. 

1. With Windows Explorer open your export file Greater than 20cm target length by cells.csv   
- OR - 
C:\Echoview Software\Tutorials\IntroToMultibeamTargetDataProcessing\Greater 

than 20cm target length by cells (Solution).csv 

2. Select the whole sheet. 

3. On the Excel Data menu click Sort 

4. Under the Sort by section: 
Select Num_targets, Smallest to Largest 
Click OK. 

5. Delete all rows where Num_targets equal 1 or -1, to remove invalid fish tracks. 

6. Select the whole sheet. 

7. On the Data menu click Sort. 

8. Under the Sort by section: 
Select Region_ID, Smallest to largest 
Click OK. 

9. Save the sorted file as Greater than 20cm target length by cells.xlsx 

Excel Workbook – Calculations and graphs 

The prepared fish track data is copied to an Excel workbook that has been configured to run pivot table 
calculations, formulas and plot graphs. 

The workbook has been set up to use prepared fish track analysis data. The prepared data must be copied to 
the Fish tracks worksheet.  

If you want to use the data exports from Topic 6, use your saved .xlsx file or use the data from Greater than 
20cm target length by cells (Solution).xls 

1. Using Windows Explorer open Statistics and Fish Flux (Solution).xlsx 

2. The worksheets of the workbook solution file have been protected (in a simple way, no password is used). 
To remove the protection for each sheet do the following: 
On the (Office 2010) Review menu select Unprotect Sheet 

3. Examine the calculations and graphs in the workbook.  
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Tips 

• You can use the workbook as a template for fish track analysis data exports that contain different analysis 
variables than those specified by this Echoview tutorial set. However you may have to reconfigure the 
source data for tables and graphs. 

o Refer to the Echoview Help file for more information regarding: 

o About fish track regions (Invalid fish tracks) 

The Statistics and Fish Flux (Solution).xlsx workbook takes the exported data and displays the ways in which 
the data may be analyzed. A pivot table may be used to calculate fish flux. Various graphs on the Histograms 
and graphs sheet show analyses of Target length mean. 

Configuration  

This worksheet defines Named worksheet variables that are used throughout the workbook.  

 

Figure 19. The Configuration worksheet. 

Intermediate Calculations  

This worksheet displays intermediate calculations for fish count and fish flux. Formulas use Excel Lookup 
functions and Named variables.  

  

Figure 20. The Intermediate calculations worksheet, data for a pivot table is displayed on the sheet. 

 

Figure 21: Area used for pivot table calculations. 
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Histograms, graphs 

This worksheet displays examples of how you can graph the detected fish tracks. Using other fish track data 
will require adjustments to formulas and the re-specification of graph data sources to suit. 

Target length histogram: 

Next to the Target length histogram graph, an area is reserved to calculate the target length frequency 
distribution. The Bins column holds the target length bin values that the Excel Frequency array function uses 
to sort target length data. The Frequency column is the space where the Frequency array places its results. 
Refer to online learning materials to find out how to set up and evaluate the Frequency array function. 

Other graphs: 

The XY graphs plot X - Target length data and Y – various fish track data. 

The XYZ graph plots X, Y and Z data. In this example, the Z data is speed. Bigger circles represent higher 
speeds.  

Basic statistics and fish flux  

This worksheet displays downstream calculations for: 

• Fish number via a pivot table. 

• Fish number/hour via a formula that sources data from the pivot table and the workbook. The Net flux 
represents the net number of fish per hour. The Upstream direction is positive and Downstream is 
negative.  

  

Figure 22. Basic statistics and fish flux worksheet, there are no data for Uncertain or Upstream categories in the exported 
fish tracks. 

Tip 

New data on the Intermediate Calculations page may require an Excel Refresh All for the pivot tables. 

Fish Tracks  

This worksheet contains processed fish track analysis export data. 

  

Figure 23. Fish tracks worksheet. 
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Topic 8: Using a template 

In this topic you will learn how to create an Echoview template for loading multibeam data. 

About templates 

Creating new EV files based on a template is a useful way to efficiently process data in a standard way.  

Template files are "normal" EV files stored in a templates folder without any reference to echosounder data 
files. New EV files based on templates contain a one-time copy of all the settings stored in the template and 
await the addition of data files. 

Refer to the Using EV file templates page in the Help file for more information. 

Creating a template 

The MultibeamFishTrackDetection (Solution).EV file contains all the Echoview processing steps and settings 
required to prepare DIDSON data for fish track detection and fish track analysis export. This EV file can be 
used for additional data recorded under the same conditions. In effect the MultibeamFishTrackDetection 
(Solution).EV file can be used as a template. 

1. Start Echoview. 

2. On the File menu, click Open. 
Open your saved MultibeamFishTrackDetection.EV file  

- OR - 
MultibeamFishTrackDetection (Solution).EV 

3. On the Filesets window, click +.  

4. Click Fileset2, on the Shortcut menu select Rename Fileset, type Exported single targets. 
This is preparation for the template to accommodate the addition of an exported .csv file. 

5. On the File menu select Configuration. 

6. Click the File locations tab. 

7. In the Files types section click Templates. 

8. Click Edit. 

9. Browse to your tutorial folder: 
e.g., C:\Echoview Software\Tutorials\IntroToMultibeamTargetDataProcessing\ 

Click New folder. 
Type Templates to name the folder and press Enter. 
Click Select Folder. 
Click OK. 

10. On the File menu find Save Template and click Copy to New Template. 

11. Browse to the Templates folder: 
e.g., C:\Echoview 
Software\Tutorials\IntroToMultibeamTargetDataProcessing\Templates  

12. Under File name type: TutorialTemplate and click Save. 

13. On the File menu click Close. 

Using a template 

When new data is added to a new EV file based on a template, the one-time copy of the template settings is 
applied. You can then proceed to tune the settings for the new data (if required). 

Before you add data to a new EV file based on a template you can view and change the variable properties of 
“unavailable variables”. This ability facilitates work with templates and work with EV files where variables or 
data files have been removed. 

For demonstration purposes, the new data file is recorded over a much shorter time interval and there are 
three fish. 
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When you create a new EV file, Echoview will offer you a list of available templates. 

14. On the File menu click New from Template … 

15. Click TutorialTemplate.EV 

Click OK. 

16. On the Fileset 1 window click Add. 

17. Open the file 2002-07-15_#018_HF_s003.ddf:  

e.g., C:\Echoview Software\Tutorials\IntroToMultibeamTargetDataProcessing\2002-
07-15_#018_HF_S003.ddf 

18. Click the Dataflow tool  

19. Inspect the variables, virtual variables and settings in the EV file.  

20. Display the echograms for Sv frames, Multibeam target detection, >20cm lengths and Single targets 
>20cm target length. 

21. Arrange the echogram windows.  

22. Put Sv frames, Multibeam target detection and >20cm target lengths echograms into an 

Autosynchronization group . 

23. On the Single targets >20cm target length echogram use the Rectangle tool  to select the single 
targets. 

24. On the Shortcut menu select Looped multibeam replay. 

25. On the File menu click Close. 
- OR – 
Save your EV file as C:\Echoview 
Software\Tutorials\IntroToMultibeamTargetDataProcessing\TemplateWithNewData.EV 

and Close. 
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Topic 9: Performance optimization 

In this topic you will learn how to optimize Echoview’s performance with data dense files and how to deal with 
many data files in a data set. A template and original data are used to recreate target data processing. 
Selected single target data are exported and are added to a second fileset.  

Export/addition of single target data  

When viewing a single target echogram derived from the multibeam target detection variable, Echoview re-
generates data for display when you want to view data that is not on the screen. With data-dense echograms 
and a chain of virtual variables this generation process can take a long time.  

To “break” the link to the multibeam target detection variable, you can export the single target data (along with 
all the target properties), re-import the file and add it to different fileset. As a result, Echoview’s performance is 
significantly improved when you view the Sv frames echogram in synchronization with the echogram of the 
imported single target data. Note that if you want to improve any steps in the dataflow for multibeam target 
detection, you’ll need to re-export the updated targets.  

 
Figure 24 The multibeam target data processing dataflow for the tutorial’s Performance optimization section. Note the 
framed single target data in both fileset s- the variables effectively contain identical data. The single target data in the 
Exported single targets fileset will display faster than the equivalent data in Fileset 1.The dotted arrow shows the virtual 
variable calculations required for the single target data in Fileset 1. 

1. Start Echoview. 
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2. On the workspace click Create a new EV file. 

3. On the New EV File dialog box select TutorialTemplate and click OK. 

4. Under Fileset 1, click Add, browse to the file: “2002-07-15_#018_HF_S001.ddf" 

e.g., "C:\Echoview Software\Tutorials\IntroToMultibeamTargetDataProcessing\2002-

07-15_#018_HF_S001.ddf" 

5. Click Open. This recreates the MultibeamTargetDetection (Solution).EV file. 

6. Close all echograms except for the Single targets >20cm target length echogram. 

7. Click the echogram. On the Echogram menu select Export, Single Target to CSV…  
On the Export dialog box, select All measurements and click Export. 
For Filename type SingleTargetsGreaterThan20cmTargetLength. 
Click Save. This export can take some time for large amounts of data. 

8. Return to the Filesets window. 

9. Click the Exported single targets fileset tab. Click Add, browse to: 
"C:\SVN\Echoview Doc\1500\Documentation\Tutorials\Tutorials\EV and data 
files\IntroToMultibeamTargetDataProcessing\SingleTargetsGreaterThan20cmTargetL

ength.target.csv" 

Click Open. 

10. Select single target detections comma-separated values. 

11. Click Echogram. 

12. Click the Variable Properties tool . 

13. Click the Echogram Display tab. 

14. This step will display the .csv data so that you can compare it with the original single target data. 
 
In the Echogram colors section: 
Color display minimum: 70 
Color display range: 40 
Color scheme: EK500  
 
In the Echogram display limits section: 
Upper display limit: 3 
Lower display limit: 12 
 
Under the Data tab, Single target settings section: 
Upper detection range: 0.00 
Lower detection range: 12 
Thickness source: Target thickness 
Thickness factor: 0.75 
Click OK. 

15. Display these echograms, side by side: 
Sv frames echogram 
Single targets >20cm target length echogram 
Exported single targets: single target detections comma-separated values echogram. 

16. Use Window menu > Arrange All. 

17. On the Shortcut menu select Synchronize. 
Observe the two single target echograms – the displayed data are equivalent. 

18. Close the Single targets >20cm target length echogram. 

19. Click the Sv frames echogram. 

20. Click the Autosynchronization tool . 

21. Click the Exported single targets: single target detections echogram. 
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22. Click the Autosynchronization tool . 

23. Use the Time slider to run forward and backward through the data. 
The Exported single targets echogram responds quickly to changes in the position of the Time slider. 

24. On the File menu click Close. 
- OR – 
Save your EV file as  
C:\Echoview 

Software\Tutorials\IntroToMultibeamTargetDataProcessing\TemplateWithExportedDa

ta.EV 

Note: On the Dataflow window, the Exported single targets: single target detections comma-separated values 
variable may not be displayed. If not, place the mouse pointer over an empty space in the Dataflow window 
and use the right-click menu, Show. On the Show In View dialog box, select the item for Exported single 
targets: single target detections comma-separated values. Click OK.  

COM Scripting  

COM scripting is a powerful tool to process multibeam data files in Echoview. Many similar files can be 
processed quickly so that EV files and export files are ready for the review stage. Refer to the Echoview Help 
file for more information regarding COM scripting. 

To complete this exercise, Echoview requires a license for the Automation module. 

An example COM script has been prepared for this tutorial topic. 

The COM script:  

• Uses a template file:  
e.g., C:\Echoview 
Software\Tutorials\IntroToMultibeamTargetDataProcessing\Templates\TutorialTemp

late.EV  

• Processes raw data with the template. Raw data files:  
2002-07-15_#018_HF_S001.ddf 
2002-07-15_#018_HF_S003.ddf 
Found in the following example path: 
C:\Echoview Software\Tutorials\IntroToMultibeamTargetDataProcessing 

Description of steps in the COM script  

1. Create a new EV file using the template. 

2. Add a data file to “Fileset1”. 

3. Export single target data from single target echogram to  
“Script DataFileName single targets GT 20cm target length.target.csv” 

4. Add the exported single target data to the “Exported single targets” fileset. 

5. Detect fish tracks on the original single target echogram. 

6. Export, Analysis by regions, Fish tracks to “Scripted DataFileName fish tracks GT 20cm target length.csv” 

7. Save the EV file to “DataFileName Greater than 20cm target length.EV” 

8. Repeat the process for any other data files in the specified location. 

 

Run the script 

1. Start Echoview. 

2. Use Windows File Explorer to navigate to the following file in the tutorial folder: 
MultibeamTargetDataProcessing(COM script).vbs 

3. Double-click the file MultibeamTargetDataProcessing(COM script).vbs 

4. Click OK when the script message appears. 



 

Echoview Tutorial: Introduction to Multibeam Target Detection Page 44 of 46 

 

5. The COM script saves and closes the new EV files. 
The data files used are those that were used for the tutorial exercises. The script will produce viable fish 
track and single target export files. The new EV files that could be tuned further to achieve better 
detections. 

6. Open the new EV files and inspect the echograms.  

7. Close Echoview. 

8. Use Windows File Explorer to inspect the exported CSV files in the 
MultibeamTargetDataProcessing folder. 

 

Further information 

• Echoview does not need to be opened for the COM script to work. If Echoview is not opened beforehand 
the script will use the system’s last opened instance of Echoview.  

• If you want to view the .csv files in parallel with the new EV files, you will have to make copies of the .csv 
files. 

• To learn more about COM scripting you can download example scripts and a tutorial from the Echoview 
website.  
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Appendix 1: Stages of Multibeam Target data processing workflow 

The analysis of multibeam data can be done in two stages: Development and then Routine analysis. 

Development  

The development stage characterizes the nature and limits of the data set. Different analysis pathways and 
parameters are explored to optimize target detection. Intermediary steps are examined to identify where 
problems occur and how they propagate through later processing steps. The Development stage would 
probably work with one data file at a time. 

1. Load multibeam data files (typical, worst-case, best-case, unusual cases, etc.). 

Experiment with: 

o Multibeam Background Noise removal 

o Convolution and filtering 

o Multibeam target detection 

2. View resulting echograms and compare with original multibeam data. Assess what steps and settings best 
preserve target size and area. 

3. View the single target echogram that is the optimization of Step 1 and Step 2. 

Check target traces (this is before tracking). In ideal data, traces should be complete (no missing pings) 
and should not split or merge. Compare individual traces that show problems with the original multibeam 
image. 

For example, if target traces split the problem may be that the tail image separates from fish body image. 
This may be resolved through the adjustment of settings. Adjust if necessary and review results. This is an 
iterative process. 

View the single target echogram for estimates of other target attributes. Compare values of individual 
single target echoes with the corresponding target image on the multibeam echogram. 

Replay the multibeam echogram frame by frame and observe what happens to feature values. Look for 
unexpected values or patterns. Re-examine intermediary results from Step 1 to track an unexpected value 
to its source. This is an iterative process. Review, learn and improve. 

4. For Steps 2 and 3 it is critical to have an exact alignment of single beam and multibeam echograms, i.e. 
exactly the same range interval needs to be shown, so you can relate the fish image on the multibeam 
echogram to the corresponding trace on the single target echogram. A vertical line on the echogram 
indicating the current frame helps relate the fish image to the corresponding single target echo. 

5. When satisfied with the above, track single targets. Experiment with fish tracking parameters; perhaps 
generate several sets of tracking parameters, tailored to different environmental conditions or fish 
behavior. Review tracking results on the single target echogram; review the corresponding multibeam data 
in the manufacturer’s application where tracks are questionable. Tweak tracking parameters to minimize 
the amount of editing that is necessary.  

6. Make manual length measurements. Make on-the-fly comparisons with automatic measurements. Spread 
manual measurements over time, range, groups of fish etc. 

7. Export tracked single target data. Plot manual vs. automatic measurement. Check correlation. If 
correlation is poor or inconsistent with previous correlations examine frames one by one to find the cause 
of the problem. (View the multibeam echogram and single target echogram side-by-side.) Possibly make 
adjustments to steps 2.  
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Routine analysis  

The routine analysis stage estimates the rate of observed fish. 

Identified methodologies from the development stage are used for routine analysis in a two part process. 

The first part of the process is time-intensive and does not require user interaction. This can be achieved by 
running scripts in the background to produce pre-processed EV files and exported target data. 

The second part of the process covers review, editing, and manual measurements and requires user-
interaction. This is achieved by working with pre-processed and exported data in Echoview. 

1. Run script for pre-processing. Use the set of image processing steps identified in the Development stage. 
Script will run in background and do the following:  

a) Load files into “Processing EV” file (contains all variables for processing steps b - e).  

b) Background Noise Removal.  

c) Target definition via using convolution, filtering and thresholds.  

d) Multibeam target detection.  

e) Conversion to single targets.  

f) Export single targets to cut the data link to multibeam data - this avoids time-intensive 
recalculation of single targets in Echoview 

g) Load single target and multibeam data files into a “Review EV” file. 
Review EV contains original multibeam data files and TS substitution single target variables - one 
variable for each estimated target attribute. 

h) Track fish 

2. Open the “Review EV” file 

3. Manually edit e.g. boat wakes or floating debris. 

4. Make manual length measurements. 

5. Review fish track detection, 

6. Export tracked single target data, including manual length measurements. 

7. Review the correlation between manual and estimated length measurements, if acceptable then move on 
to Step 8, otherwise make manual measurements for all “candidate” fish. Could use a combination of 
target property echograms as a guide to which fish to measure. 

8. Summarization: calculate fish of given size class per hour. This step is best done in a third party 
application. 
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