Using EV files

Before any work can be done with the data stored in data files you must open an EV file and add data files to the EV file. It is not possible to open a data file directly with Echoview.

An EV file can contain a number of different groups of data files, each group stored in a fileset. One EV file can contain one or more filesets.

The Filesets window is used to manage filesets, related variables and data files. It contains as many pages as there are Filesets.

When the data in a data file are first accessed in Echoview, index files called EVI files are created in the same folder as the data files. EVI files speed up access to data on subsequent reads.

Many parameters that are essential to the analysis of your data are properties of the EV file.  EV file properties affect all variables in the EV file - not just single variables.  For example, the bottom detection algorithm is an EV file property, and the same algorithm will be used with all variables.  It is essential to review all EV file properties and ensure that any which are relevant to your analysis are set.  If a parameter is not set as an EV file property then it is likely to be a variable property.

See also: Support characters for file names.

Creating EV files

To create an EV file:

  1. On the File menu, click New.

  2. If the New EV file dialog box is displayed:
    Select a template on which to base the new EV file and click OK.
    - OR -
    Click No template.

Saving EV files

To save an EV file and overwrite the previous version (if any):

  1. On the File menu, click Save.

  2. If the Save As dialog box is displayed; select a folder in which to save the file, enter a file name, and click Save.

Note: When overwriting an EV file, a backup file is created.

To save an EV file without overwriting the previous version:

  1. On the File menu, click Save As.

  2. Select a different folder and/or enter a different file name.

  3. Click Save.

Saving EV file templates

Refer to About EV file templates for information about templates.

To save a copy of the EV file as a template:

  1. On the File menu, point to Save Template and click Copy to New Template.
  2. Use the folder offered or select a folder or create a new folder and enter a file name.
  3. Click Save.

To save a copy of the EV file as a Live viewing template:

  1. On the File menu, point to Save Template and click Copy to New Live Viewing Template.
  2. Use the folder offered or select a folder or create a new folder and enter a file name.
  3. Click Save.

Opening EV files

To open an EV file:

  1. On the File menu, click Open.

  2. Select the required EV file.

  3. Click Open.

EV files can also be opened by double clicking on the EV file name in Windows Explorer.

Hint:  If Echoview cannot find the data files to which the EV file refers, it will display a dialog box that allows you cancel the open command or specify a new location for the files. If you want to specify a new location for the files and already know the location; click Yes, select the folder (the OK button will become active when you select the folder that contains the file), and click OK. If you want to specify a new location for the files but do not know where the files are stored, you can search for the files in Echoview but may find it easier to click Cancel, find the location of the files using Windows Explorer (or another external application rather), then re-open the EV file and browse to the required folder.

Notes:

Working with EV files from an earlier version of Echoview

If you are opening an EV file that was saved in an earlier version of Echoview, you may be required to make changes to the EV file to ensure it is compatible with the current version of Echoview, see:

To check which version of Echoview was last used to save an EV file:

  1. Open the EV file.

  2. On the View menu, click EV File Properties.

  3. Click the Notes tab.

  4. Check the version number in the EV File Saved by box.

Note: If you save an EV file using a new version of Echoview you will no longer be able to open it in an older version of Echoview. A backup file is created however.

See also

EV file properties dialog box
Adding and removing data files

About viewing data

About file management