About exporting analyses
Echoview is able to export a variety of analyses of data. Such exports are distinct from exporting data.
Analysis by region, cell or transect
Analysis export data can be exported in Database and Spreadsheet formats.
Analysis calculations can include and/or exclude data as directed by specific property settings. For further details, refer to About analysis domains. Refer to the settings on the Analysis page of the Variable Properties dialog box that affect your results, and the settings on the Export page of the EV File Properties dialog box to configure your analysis export results.
The results from any analysis are restricted to the analysis domain overlapping with any transects in an assigned transect group. Refer to Transects and export analyses for more details.
|
Export type |
Available from |
Analysis by Regions |
Analysis by Cells |
Analysis by Regions by Cells |
Analysis by Regions by Region Track |
Analysis by transects |
|
Sv sample integration |
N/A |
|||||
|
N/A |
N/A |
N/A |
N/A |
|||
|
N/A |
||||||
|
Single targets frequency distribution |
Frequency distribution of single targets by regions by cells |
N/A |
N/A |
|||
|
N/A |
N/A |
N/A |
||||
|
Region track analyses |
N/A |
N/A |
N/A |
N/A |
||
|
ICES analysis CSV |
N/A |
N/A |
N/A |
|||
|
Wideband frequency response |
N/A |
N/A |
N/A |
N/A |
||
|
Sv pulse compressed wideband pings echogram |
N/A |
*The Echoview ICES .csv export supports single beam Sv data from any file format. But be aware that ICES website data collections may only support single beam Sv values for HAC *.hac, BioSonics *.dt4 or Simrad *.raw file formats.
For information about whether exported latitude and longitude values have been corrected for transducer geometry, see What is affected by transducer geometry.
Notes:
- Calibration settings for analysis exports are specific to each variable, and are not included in export data.
-
Data management tips:
- To ensure that you have a permanent record of the calibration settings for your export, create a read-only folder to store your export data.
- For each export, save a copy of the EV file to the folder path of the export.
- Exported cells are referred to by layer and interval numbers. Layers and intervals result from settings on the Grid page of the Variable Properties dialog box. Layer numbering is sensitive to the Echogram mode and to the Depth\range\Line-referenced setting on the Grid page of the Variable Properties dialog box. Layers can be referenced to a Surface (depth of zero), Transducer face (range of zero) or specified line from the EV file.
- For each export option, there are mandatory analysis variables, but you may also select optional analysis variables to output additional information related to the analysis and analysis domain. For more information refer to About analysis variables.
- Region by Cells known issue.
- A licensed Schools detection module is required for the export of Schools module analysis variables with an Integration by regions export.
- A fixed platform affects SHAPES variables and other associated analysis variables.
- Region Integration by Cells.
- Sv integration on Sv pulse compressed wideband data supports optional wideband analysis variables.
- Analysis exporters can either use the global output settings from the EV File Properties dialog box or, where available, an exporter-specific override. When Override the output settings specified within the EV File Properties dialog is selected on the Exporter Properties dialog, both validation (e.g., format compatibility warnings) and the export itself use the exporter's own settings rather than the global settings.
- A series of Sv sample integration values for intervals can be output by an Interval analysis time series operator.
Cancel export
An Export analysis dialog box with a progress bar and a Cancel export button is displayed for all the Analysis by region, cell or transect exports, and the Wideband frequency response export.
Notes:
- The Cancel export button allows users to manually stop the export process at any time.
- Echoview cancels the export when the acoustic variable is changed while the export is in progress and a a warning message will appear to notify the user. An example of such a change is an ECS file update.
- When an export is canceled, writing to the export file ends and the file is saved as is.
- Export analysis changes for new EV files under Echoview 12.
Other analysis exports
Data created by Echoview detections and types of analysis can be exported in .csv formats.
Export type |
Available from |
With an active |
Use |
Single target echograms |
Selection or region |
Shortcut menu (right-click), Export Selection, Single Targets to CSV Shortcut menu (right-click), Export Region, Single Targets to CSV |
|
Single target echograms |
Selection or region |
Shortcut menu (right-click), Export Selection, TS Frequency Distribution Shortcut menu (right-click), Export Region, TS Frequency Distribution |
|
Target length echograms |
Selection Target length echogram |
Shortcut menu (right-click), Export Selection, Target Length to CSV Echogram menu, Export, Target Length to CSV |
|
Target length echograms |
Region |
Shortcut menu (right-click), Export Region, Length Frequency Distribution |
|
Multibeam target echogram |
Multibeam target echogram |
Echogram menu, Export, Multibeam target to CSV |
|
Multibeam echograms |
Multibeam echogram |
Echogram menu, Export, Multibeam Bottom Preview Samples |
|
Cruisetrack window Table window |
Cruisetrack menu, Export Data Table menu, Export Data |
||
Selection or region on a pulse compressed wideband echogram linked to the Wideband frequency response graph |
Graph window |
Graph menu, Export Data |
|
Single target detection - wideband echogram with an export dialog box that specifies variables and calculation parameters |
Selection or region on an echogram |
Shortcut menu (right-click), Export Selection, Wideband Frequency Response Shortcut menu (right-click), Export Region, Wideband Frequency Response |
|
Sv pulse compressed wideband echogram |
Sv pulse compressed wideband echogram |
||
Single target detection - wideband echogram |
Single target detection - wideband echogram |
Create a Wideband frequency response - Single targets exporter |
|
3D regions in a scene |
Scene window |
3D object, Shortcut menu (right-click), Export Region Inspection Data |
|
Single beam echograms |
Single beam echogram with a specified Threshold offset line and bottom line as an operand for a Vegetation analysis exporter |
||
Selection or region on a Single target detection - wideband echogram |
Save Report... |
||
Sample analysis exporter with a linear operand Interval analysis time series with a linear operand |
Configured Sample analysis exporter on the Dataflow window. Configured Interval analysis time series on the Dataflow window. |
On the Dataflow window double click the configured on Sample analysis exporter. On the Dataflow window, click the Interval analysis time series object, right-click, select Export, To CSV... |
|
Sample analysis exporter with a supported dB operand Interval analysis time series with a supported dB operand |
Configured Sample analysis exporter on the Dataflow window. Configured Interval analysis time series on the Dataflow window. |
On the Dataflow window double click the configured Sample analysis exporter. On the Dataflow window, click the Interval analysis time series object, right-click, select Export, To CSV... |
Notes:
- Right-click to display the Shortcut menu.
- Some exports to CSV may display a Cancel export button.
- See also: data CSV exports from Interval analysis virtual variables that output a time series for analysis variables (Sv or single targets or bottom feature).
See also
About analysis
About analysis variables
About on screen analyses
About exporting data
Export variable lists
Special export values